Backup Options in Mac OS X
INTRODUCTION

Apple feels so strongly about the need for good backups that they’ve built a
backup feature called Time Machine into Mac OS X 10.5 Leopard.

You know that backups are important, but when it comes to backing up a
computer, the options are so numerous that we can find it difficult to wade
through them and make intelligent choices. Which files should you back up?
How often, and onto what media? Do you need to make bootable backups?
How many sets of backup media do you need? Which backup software
should you use? And what exactly do you do in case of a disaster, when you
need to restore files from those backups?

DECIDE ON A BACKUP STRATEGY

Understand the crucial differences between a duplicate (a complete and
usually bootable copy of your hard disk) and an archive (containing multiple
copies of files as they existed at various points in time). Understand why a
good backup strategy includes both.

YOUR MISSION

Number One: Make a bootable copy of your hard disk and test it to make
sure it works. Number Two: Configure an archive for your most frequently
used data files, and verify that you can retrieve stored files. Number Three:
Put backing up on autopilot so your files are protected even when you aren’t
paying attention.

QUICK ARCHIVE:

Okay, if all this sounds too over-the-top for you, listen up. Mac OS X comes
with a feature called Burn Folders. Create a burn folder in Tiger, which you
do by either choosing New Burn Folder from the File menu or from the
Action menu, that’s the button with a gear icon on it in Finder windows. If
you look inside that folder, you won’t see your original files. Instead, you’ll
see aliases to the originals. You can tell they’re aliases because they have a
little curved arrow on them. But don’t let that throw you. When you do



finally click the burn button in the upper right-hand corner of the burn
Folder’s window, it actually gets the original files and burns those to disk.

Make a new burn folder and name it AMS for Address Book, Mail, Mozilla
and Safari. Open your Library folder and then Application Support. Drag the
Address Book folder to the new burn folder. It becomes an alias. From the
Library folder drag the Mail, Mozilla and Safari folders to the burn folder
too. Click the Burn button in the top of the folder window. Insert a CD. Give
the CD a name and include today’s date. Click burn. Store the CD in a safe
place. Do this every Friday. Good habits lead to virtue. Virtue leads to inner
peace. To restore the files drag them back to their proper places. Click the
Replace button when asked.

SAMPLE BACKUP APPROACHES:

You will get out of your backup system what you put into it. If saving
money is your objective, use your Mac’s SuperDrive. Every month burn a
DVD of your entire home folder from the Finder using a burn folder. The
home folder must be smaller than 4.7 GB. For a little more control, invest in
some backup software: SuperDuper! or Apple’s Backup 3 program for
Mobile Me (Dot Mac) users. Apple’s Backup software contains “Plans”
which are configurations of some basic strategies for burning the home
folder to DVDs monthly and backing up your personal data to the iDisk
daily.

[Show Backup 3. Double-click plan. New Plan.]

Add an external firewire drive, and use one of the backup software programs
for a weekly clone of the entire hard drive. Have the software do daily
archives of the changed files. If this seems excessive, do a full backup
monthly, and weekly archives. Read your backup software’s instruction
manual for these tasks.

Apple’s Disk Utility, included with Mac OS X, can make bootable
duplicates. Open Disk Utility from the boot drive and select the Restore tab.
Drag the external hard drive from the Disk Utility left sidebar to the field
marked Destination. Drag the Mac’s internal hard drive from the left sidebar
to the field marked Source. Click the Restore button.

[Show Disk Utility backup to external drive.]



CHOOSE YOUR HARDWARE

Having an external hard drive is preferred over backing up to a partition on
your internal drive. Hard drives have the virtues of speed and capacity. CDs
and DVDs do not require the purchase of additional hardware if you already
have a SuperDrive. Use these for the weekly AMS archive.

EXTERNAL FIREWIRE DRIVE

An external hard drive should be partitioned into two volumes, one for a
duplicate (clone) and another smaller partition for archives. How large does
the drive need to be? As a rule of thumb, a destination volume should have
between 1 and 1.5 times the capacity of the data on the source volume.
Select your hard drive’s icon in the Finder and choose File > Get Info. The
figure next to the word “Used” is the amount of space the data currently
occupies. For archives use Get Info to determine the size of your home
folder. Multiply that by 1.5 for the amount you need. For example, on a 60
GB hard disk, you currently have 20 GB of data in total, of which your home
folder, not counting excluded files, is only 6 GB. If you allow 30 GB (20 GB
x 1.5) for a duplicate, and 9 GB (6 GB x 1.5) for an archive, that yields 39
GB. Resist the temptation to save money by purchasing a 40 GB disk,
because sooner or later, you’re likely to fill up that internal disk and wish
you had more backup space. You know the saying: you can never have too
much money or disk space. Buy a 60 GB disk—or, if you can afford it, an 80
GB disk.

Get a drive with the fastest interface your computer supports. FireWire 800
and USB 2.0 are faster than FireWire 400, which is much faster than USB
1.1. If you have an Intel Mac with any version of Tiger (10.4) on it and make
a duplicate of your startup volume, that volume will not boot a PowerPC-
based Mac; likewise, a duplicate of a PowerPC-based Mac’s Tiger startup
volume will not boot an Intel Mac. Apple is expected to eliminate this
inconvenience with the release of Mac OS X 10.5 Leopard, which should be
a universal system that will boot Macs with either type of processor.

Here's a step by step to follow for formatting a hard drive with Disk
Utility:

To be able to boot from an external/internal drive with an Intel-based



Mac, partition it using Disk Ultility, selecting the GUID option:

1. Select the drive's icon (not the indented volume name) in the left column.
2. Click the Partition tab on the right.

a. Type a name for the drive; Volume Scheme: 2 Partitions

b. Verify that the "Format:" field says "Mac OS Extended (Journaled);

c. click the <Options...> button.

In the Options drop-down dialog, ensure the <radio button>

next to "GUID Partition Table" is selected and click the <OK> button.

3. Click the <Partition/Apply> button on the lower right.

To be able to boot from an external/internal drive with a PwrPC-based
Mac, partition it using Disk Ultility, selecting the APM option:

1. Select the drive's icon (not the indented volume name) in the left column.
2. Click the Partition tab on the right.

a. Type a name for the drive; Volume Scheme: 2 Partitions

b. Verify that the "Format:" field says "Mac OS Extended (Journaled);

c. click the <Options...> button.

In the Options drop-down dialog, ensure the <radio button> next to "Apple
Partition Map" 1s selected and click the <OK> button.

3. Click the <Partition/Apply> button on the lower right.

CHOOSE YOUR SOFTWARE

The following applications offer both duplication and archiving, as well as
scheduled backups:

* Backup Simplicity
* Data Backup

* D¢ja Vu

* Retrospect Desktop
* Retrospect Express
* RsyncX

* Synchronize! Pro X
* Synk Pro

* Tri-Backup

The following applications create bootable backups but not additive
incremental archives:

* BounceBack Professional

* Carbon Copy Clonerl

* Clone’X



* CopyCatX

* FoldersSynchronizer

* MimMac

* Personal Backup X4

* SilverKeeper

* QuickBack (part of SpeedTools Utilities)
* SuperDuper!

* Xupport

The following applications offer additive incremental archives, but lack the
capability to create bootable backups:

* Apple Backup 3 (but not earlier versions)

 Archive Assistant (part of Stufflt Deluxe 10.0 and later)
* BackupSW

* BRU LE

* ChronoSync

* Dobry Backuper

* NTI Shadow

» SwitchBack

» SmartBackup

If your external hard drive comes with a backup program, use it. Schedule a
duplicate (clone) backup for every week and incremental backups every day.

DISK UTILITY COPIES

Now that the external hard drive 1s properly formatted, it is ready to hold a
duplicate of your hard drive. Launch Disk Ultilities in the Utilities folder.
Click the Restore tab. Select the internal hard drive as the source and the
external drive as the destination. Check the box to Erase destination. Click
the Restore button.

RESTORE DATA FROM BACKUPS

Test the basic process of booting from a duplicate and restoring individual
files from an archive. But in the event your data suffers serious damage, you
will want to restore your duplicate, archive, or both onto your main hard
disk. If your startup disk becomes unusable, you should not copy other files
onto i1t while 1t’s still in an unstable state. In case of serious trouble, the first
thing you should do is start up your computer from another volume (a



duplicate, a Mac OS X installation CD, or a bootable disk-utility CD such as
Alsoft’s DiskWarrior). Run Disk Utility or another disk-repair tool to fix any
errors on your hard disk. If you’re planning to restore all your files, it makes
sense to erase the disk first, whether it appears to have any errors or not.

If you’ve booted from your duplicate disk and erased your primary disk,
restoring the duplicate onto the primary disk is a piece of cake. Follow the
same steps in the software you normally would to create a duplicate, but
choose your external disk as the source and your internal disk as the
destination. When the duplicate is complete, use the Startup Disk pane of
System Preferences to set your internal disk as the startup volume, and
restart the computer. If all goes well, your Mac will boot properly from the
freshly restored duplicate on your primary disk. Now restore your latest set
of archived files as well.

RESTORE A CD/DVD DUPLICATE ONTO A HARD DISK

Let’s say you have a duplicate of your hard disk stored on a stack of CDs or
DVDs. Now it’s time to restore them onto your hard disk so you can boot
from your duplicate, but your internal hard drive is the only one you have.
So there’s a problem: If you boot from the internal hard drive (assuming it
even has a functioning system), you won’t be able to restore the duplicate
because that would overwrite files that are actively in use. On the other
hand, if you have only one optical drive, you can’t boot from that either,
because you would then be unable to remove the boot CD/DVD to feed in
the backup discs. What to do? The process is tedious, but it can be done.
Follow these steps:

1. Start up your computer from your Mac OS X installation CD or DVD that
came with your computer or one you purchased separately.

2. When the first installer screen appears, choose Installer > Open Disk
Utility.

3. When Disk Utility opens, select your hard disk, click the Partition tab, and
set up at least two partitions on the disk. (If your disk is already partitioned,
you can skip this step.) Your goal is to have one partition that’s large enough
to hold the restored system and another that’s large enough to hold a basic
installation of Mac OS X. For the latter, a 5 GB partition should be adequate.
(Caution: Partitioning your hard disk erases all the data on it.)

4. Quit Disk Utility, return to the installer, and install Mac OS X onto the
newly created (small) partition. When asked to choose an installation type
(the default is Easy Install), click Customize.



Deselect everything except BSD Subsystem. Now proceed with the
installation.

5. When the installation is complete, restart your computer from the copy of
Mac OS X you’ve just installed on your small partition.

6. Reinstall your backup software onto the small partition that is currently
functioning as your startup volume.

7. Use your software’s duplication or restore feature to copy your duplicate
from your CDs or DVDs onto the larger partition of your hard disk.

8. Use the Startup Disk pane of System Preferences to select your freshly
restored volume as the startup disk, and restart your computer. You’ve now
restored your duplicate from optical discs onto your hard disk.

TIME MACHINE AND ARCHIVES

Mac OS X 10.5 Leopard’s Time Machine feature promises to take archives
to an entirely new level. If you decide to use it, you’ll start by designating a
volume—an external hard drive, a second internal drive, or a network
volume—to store your backups. You’ll optionally tell Time Machine which
files to exclude, and at what time of day to run its backups. Then, every 24
hours, it’ll make a copy of all your files except the ones you excluded,
leaving previous versions intact. So far, that sounds much like ordinary
archives.

Time Machine offers a couple of twists, though. First, when you need to
restore a file, you won’t have to open a separate application or search
through confusing lists. You’ll click an icon in your Dock or press a few
keys, and find yourself looking at a groovy 3-D interface in which you can
zoom backwards in time to see how any folder or volume looked on any day
in the past. When you find the version of the file you want, you just select it
and it’s magically restored to its proper home. Second, Time Machine will
work not only with whole files in the Finder but with individual entries in
programs such as Address Book and iCal, as well as within applications such
as 1Photo and iTunes. So you’ll get much more granular control over
restoring data than is possible today.

Time Machine will have you abandoning other archiving programs in its
favor. However, it’s not a complete backup solution:

* Time Machine does not create bootable duplicates; you’ll still need another
program to do that.



* I[f you prefer to encrypt your backups as a security precaution, Time
Machine won’t do the job.

* You can’t adjust the backup schedule to be more (or less) frequent than
once a day, and you can’t use removable media (CDs or DVDs) as your
destination.

* I[f you need to back up multiple computers over a network, consider
Apple’s Time Capsule.

Time Capsule is a backup device that works wirelessly with Time Machine
in Mac OS X Leopard. It automatically backs up everything. Time Capsule
is also a full-featured 802.11n Wi-Fi base station. Every computer in your
house can work off a wireless network at blazing speeds. And they can back
up wirelessly to the same Time Capsule. Its massive 500GB ($299) or 1TB
($499) server-grade hard drive gives you all the capacity and safety you
need.

Appreciate the convenience of Time Machine, but remember that it will be
just one part of a complete backup plan.

CONCLUSIONS

Remember that you get out of a backup system what you put into it. The
data on every Mac should be backed up to protect you against theft,
hardware failure, user error, and other catastrophes. Go home and make your
AMS archive using a burn folder and your Mac’s CD burner.



